My Pure i9 stopped connecting to internet

My Puer i9 used to work fine, but has not stopped connecting to internet. The robot appear off line in the app.

I have tried all the usual tips; turning the robot completely off, removing the batteries and restarting. I have also tried to set it all upp from the beinning, but at the stage when the robot should connect to the internet it fails and time out.

What is the problem?


  • I have the same issue since the app updated. Cannot connect to the pureI9

  • same here, it kept showing cannot connect to server. The new app is worse than the previous app.

  • I have the same problem too.
    How can we solve this issue.

  • Hi,
    Could you please give some more info on where you are in the world and how the problem is showing up. We would like to understand this and solve it as soon as possible

  • My PURE i9 used to work fine, but stopped connecting to internet. I tried all the usual tips, but the time is not displayed, all the time just appears -- --. In the application, the error S: 417 pops up when checking the software version.

  • CzartCzart
    edited March 14

    I have the same. Krzysztof are you from Poland?

  • I have latest firmware. There is now connection with pure via internet only in local network. Time is not displayed. I can’t see pure and its map in the app (see photo). And error s:417 in app.

  • My pure i9 went to warranty repair. After talking to the service, I made all the recommendations of the service, batteries taken out for 8 hours, new installation in the app, early reinstalled on the phone and nothing helped. And so above.

  • Service in poland for those vacuum cleaners in Poland - Unitron in Radom.

  • Hi @Krzysztof and @Czart,
    Could you please collect the logs from the robot? There is a USB port hidden under the dustbin, behind the small rubber flap. If you connect it to a computer, you'll find some files. Please send a private message to me, with the files attached.

  • Ok. I will send asap. Thx.

  • Ok I will try send.

  • By the way - what internet provider are the two of you using?

  • Multimedia Polska.

  • telkab Polska

  • Thanks. Czart, I've sent on the issue to our connectivity team, who will try to figure out why the robot cannot connect. They have some ideas.

  • When did the problems start for you? Do you remember? What is the timestamp of the last entry in your cleaning history?

  • The last timestamp is form 04.03.2019.

  • *from

  • I am on to my 2nd one and I'm having the same issues again. Both only worked for about 1 week. Ive tried to reset it, downloaded the app again and nothing changes. After the money I spent on it I am very disappointed and frustrated with the product and want my money back to buy another brand.

  • @dknight, sorry about your bad experience. The fault seems to be related to a new certificate rolled out for the cloud server, which is used for encrypting the connection. Still don't know the root cause though.

  • @dknight, is it possible for you to collect the logs from the robot using the USB port under the dustbin? Also, where are you located?

  • @Krzysztof, looking at the cloud, it seems like the robot is now online again - is this true?

    @Czart, you're still experiencing the problem, right?

  • CzartCzart
    edited March 29

    No changes. 😕

  • No changes

Sign In or Register to comment.