Persistent problem connecting to the Electrolux cloud?

markTmarkT Member, Administrator admin
edited February 2021 in Tips and Tricks

Some robots have not been able to connect to the Electrolux cloud since the end of November. There seems to be a problem which prevents some robots from correctly establishing the time and date via the internet and this can lead to the robot not being able to connect.

If you don't have connection problems with your robot, then ignore this post.

The problem is not related to the robots themselves, but something in between the robot and the internet (local router settings? ISP settings? not necessarily under your control or ours). Most robots are not affected by this, but we have made a new firmware release for those who are.

If you do have persistent connection problems, then you will understand that a normal over-the-air update won't work, so we are making the firmware available for download and installation via the robot's USB port. Please see the instructions below.

The robot can be manually upgraded using the USB connector hidden by the dust-bin.

  1. Download the right firmware for your robot. Normally the cloud picks the right version for you, but when updating via USB you need to choose: Pure i9 /Rx9 or Pure i9.2/Rx9.2
  2. Remove the dust-bin and pull out the small rubber protector for the USB port.
  3. Connect the robot to your computer using a micro USB cable, leading to it showing up as a mass storage device. NB! Some USB cables are only for charging and won't work for data transfer! Verify with other device.
  4. Put the downloaded firmware file on the device.
  5. Use the "safely remove device" option, to make sure the file is properly written.
  6. Unplug cable. Upgrade should start. If the robot says "the software is not compatible", check that you copied the right version and repeat the process if necessary. The robot should restart itself after the upgrade.

The license information for the firmware can be found here:



  • HotkiwiHotkiwi Member

    Thank you so much, this was the solution.

    But Electrolux needs to do something because how would the average 80 year old make a manual firmware upgrade ? It meant for me searching a windows machine, as apple would not recognize the external device and only the 5th USB cable was a data transfer cable.

    Buet yes, it is done.


  • markTmarkT Member, Administrator admin

    Glad it worked, sorry it was such trouble.

    This is really an unusual situation- we have never previously been in a situation which can't be fixed via an over-the-air update. I need to repeat that this particular issue only affects a small number of customers.

    Sending the product to Electrolux service is another way to have the robot's software updated, but there are many people who want a faster way to fix this issue, so we offered the USB update as a (potentially) quick solution.

  • Hi markT

    I bought a Pure i9.2 a few days ago, but I haven't been able to connect to the Cloud until now.

    I upgraded to version 41.15 but I still can't connect. I am using the latest versions of the Pure i9 and Electrolux Wellbeing applications

    On Pure i9 I can stay connected to the app via WiFi but it doesn't connect to the cloud, so I can't use most of the app's functions. At Electrolux Wellbeing, I can't even connect the robot to the app.

    What other suggestion to fix this? Do you know of any tips or changes I can make to the router ??

    I insist on having the Electrolux robot instead of other brands, but I need it to work ...


  • markTmarkT Member, Administrator admin

    Let me confirm that I have understood the problem correctly:

    You can perform the "setup new robot" steps using the Pure i app, and get through the whole process, but not the "add device" steps with the wellbeing app?

    There are a number of "pages" each app shows during this onboarding process. Can you describe which of them, if any, stalls or reports an error? Or does the connection problem only show itself after you have done the onboarding?

    Remember that the robot can only use 2.4GHz wifi (it works better than 5GHz in indoor environments) so make sure that you are trying to set it up on that kind of network.

  • markT,

    Basically I can only connect the robot to my local wifi network, it does not connect to the internet / cloud

    So I can control it trough the Pure i9 app, but I can't see the map or schedule cleaning

    Still in the advanced settings of robot in Pure i9 app, instead of showing "connected to the cloud", it shows "connected via wifi"

    In the Wellbeing app, it simply doesn't connect the robot

    I was sure that the problem is not with the robot but with the router / modem. So I had the idea to connect the Robot using the 4G of my smartphone as a router

    And it worked!!! The robot is now connected to the cloud but only through my phone's router

    I believe the problem is the router itself. However, I have more than 30 smart home devices connected to the router and none of them fail

    You should try to investigate if there is no port that needs to be open or forwarded on the router, because this persistent problem with multiple users must come from some internal configuration or port on the router ...

    I will buy another router and give you a follow up here

  • markTmarkT Member, Administrator admin

    Hold off on that router purchase for a few days (unless you really want a new one anyway...).

    We are looking into a problem at the moment which may affect your setup- it may be that the router (or the ISP) is blocking certain requests, which can cause the robot to refuse to connect to the electrolux cloud. When you use your phone as a router you not only bypass your normal router, but you usually change ISPs as well. We are looking at ways to make this work without customers needing to make changes.

  • markT

    Ok i'll be waiting :-)

    In the meantime I’m using the cell phone’s 4G to get to know the robot better

    Another observation is that both the Pure i9 app and the Wellbeign app are perfectly translated into Brazilian Portuguese, however the robot has no voice option translated into Portuguese in this firmware (41.15)

    I'm an Electrolux fan and I'm extremely happy for the support you are giving me here (Electrolux Brasil support want to send me a new robot, regardless of whether I explain that the problem was not with the robot but with the internet / cloud setup)

    Thank u so much

  • frekanfrekan Member, Moderator mod


    For those who are still experiencing problems as described above at the time of this post, we have made another release to resolve the issue. The links to the firmware in the original post have been updated and we encourage you to install it.

    We hope this resolves any remaining problems!

  • frekan,

    as i was using the robot connected by the 4g of my smartphone i received an OTA update earlier today through the Pure i9 app (even opening the Wellbeing app he did not notify about or find this update)

    Now apparently everything is working around here!

    Happy with my new robot and even happier to see that you are watching and always bringing improvements

    I just noticed a bug in both apps regarding the time, in none of them does the time match the current time where I live (GMT-3 brasil)

    that way all notifications are wrong and I can't make appointments

    is there correction for that?

    Grateful !!!

  • VimFuagoVimFuago Member ✭✭

    Just got 41.16 as on OTA update on my AEG RX9

  • markTmarkT Member, Administrator admin

    Hi Bacanasampa

    About the time zone issue- the robot should take the time zone which is set on your phone when it is onboarded. Is the phone set to a different time zone than your local one?

  • markTmarkT Member, Administrator admin


    That's right- we're pushing out 41.16 to fix the issues that a few of you have been having. There are no new features in this release, it just addresses the connection problem.

  • MarkT

    Time zone on Phone is The same as my local time zone.

    Pure i9 app and Wellbeing app are only the apps with this time problem

    How can I fix this? Looks like a problem in the cloud...

  • markTmarkT Member, Administrator admin

    A suggestion about the time zone problem:

    Now that you can connect using your local wifi instead of using the mobile phone, try onboarding the robot again (on the wifi network). You can choose "add device" and follow the steps there, but give the robot the same name, then it will appear as before in your app.

    During the onboarding procedure, the timezone is sent from the app to the robot, so if the zone is correct on the phone, this should correct any error.

    If this doesn't work, we may need to look at a log from the robot to see what is going on- I will send instructions if necessary.

  • lennonx7lennonx7 Member


  • lancelance Member


    Latest software installed via usb. as suggested above.

    Program still tries to connect through cloud which it cannot do.

    Previous version connected through my modem amd worked well. Map showing up on phone and start time setting worked. then a software update changed to the cloud and now nothing works. Will start operating manually tomorrow morning.

  • lancelance Member

    After upgrade to 41.16 through usb port, Robot has now lost everything. does nor even know the time.

    Ran cleaning manually yesterday .Robot got lost on several occasions and had to be helped out of corners. Took a lot longer than normal to clean house.

    Is it possible to reload the old version of software which accessed my modem and the old app which showed me the map and allowed setting of cleaning day and start time.

    At the moment it would be less time consuming to revert to my old vacuum cleaner.

    Any help would be appreciated.

  • markTmarkT Member, Administrator admin

    Hi Lance

    All versions of the robot software connect to the cloud via some local wifi. It could be your "modem" (I presume it has a wifi router built in?) or it could be a telephone in "hotspot" or "access point" mode. This depends on which network you paired the robot with when you set it up. None of the updates we have released have altered this.

    Does the app (doesn't matter which one) say that the robot is not connected?

    You can try the onboarding procedure again in this case. Tell the app you want to add a new device, and simply enter the same name for your robot as you originally did.

    The new app also allows scheduling of cleanings, you can find this under the "tasks" category (the middle of the three buttons at the bottom of the screen). Pick your device (robot in this case, but could also be air cleaner etc.) and then make a new task for it- e.g. clean the kitchen every day.

    It also displays maps etc. but not in exactly the same place as the old app. The new one handles multiple sorts of devices so it needs to be a little different to the old one.

  • siwuesiwue Member
    edited March 2021

    Hey there,

    I'm having a similar issue as others on this thread. My brand new Pure i9.2 won't connect to the Electrolux Cloud.

    During setup I can connect to the robot's wifi, robot will connect to his dedicated 2.4GHz network but then refuse to connect to the Electrolux Cloud.

    What I've done so far:

    1. Setup up a dedicated 2.4 GHz network for the robot.
    2. Update the firmware manually to Version 41.16.
    3. Try to setup robot with
      1. the Pure i App and
      2. the Wellbeing App.
    4. Have a beer and stare at the robot in consternation.
    5. Try to connect the robot to my phone's hotspot during setup.
    6. Have another beer and another dismayed stare at the robot.

    Is there anything else I can do to help poor little Pure i9.2 to connect to his mothership?

    (PS: Connecting my Pure A9 to the very same 2.4 GHz network works like charm.)

  • lancelance Member

    Went to the wellbeing app and re installed the robot from there. This time the app found my modem and installed correctly.

    Put the robot back on its base and the correct time showed up.

    Set the well being app to clean everywhere every Thursday at 07.30,will see what happens next week.

    As the wellbeing app does not have a map at this stage , I went to the old I9 app and set a small test zone (kitchen) that I could run to do an immediate test.

    Hit the start now and guess what. It dutifully rolled over and cleaned the small test square I had set up.

    Looks like I might have the demons beaten. Will know for sure next Thursday morning.

    Thanks for your help.


  • markTmarkT Member, Administrator admin

    Hi Siwue

    Can you say a little more about what the app says while you are trying to get the robot to connect? Which steps seem to work and which don't? Do you see an error message in the app?

    Also, try restarting the robot. Hold down the play button for like 8 sec until the robot's power level indicator (the bar of LEDs nearest the dustbin button) pulses inwardly and then goes out. After that, lift the robot out of the charger and place it back there to restart it.

  • siwuesiwue Member

    Hi Mark

    thank you for coming back to me. I have restarted the robot several times. This unfortunately did not help.

    As for the error messages, please see the two screenshots below.

    Shall I download a log file for you?



  • markTmarkT Member, Administrator admin

    Hi Siwue

    I'm sorry this is causing you so much trouble. If you take a photo of the sticker on the bottom of the robot so we can see the ID number near the barcode then we can start checking from the cloud side. If that doesn't help then we can look at logs. Can you post the photo here? Thanks.


  • siwuesiwue Member

    Hi Mark,

    Here's the sticker. Hope this information will enable you to reanimate my Pure i9.2.



  • NiclasKNiclasK Member, Moderator mod

    @siwue There was nothing obvious strange on the cloud side. Can you send us the logs from the robot? You find instructions how to get them here:

    You post them here or you can send them as a private message to me or @markT


  • siwuesiwue Member

    Hi @NiclasK ,

    I've sent a private message with the log file to Mark and you.



  • lancelance Member

    Further to my previous post on 8/Mar.

    Last Thursday at 07.30 The robot started on schedule as set up in the program. We thought wow, we must have won.

    When the first battery charge ran out, it put itself back on the charger and the app told us "cleaning is finished". I waited 2 hours to see if it was going to do the other half of the house but nothing. Pressed the start button and the robot this time cleaned the whole house, so I'm afraid the problem is only half fixed.


  • markTmarkT Member, Administrator admin

    Hi Lance

    Cleaning less than expected can be caused by a number of things-

    • maybe the robot can't find a way to the rest of the house, so it gives up and goes home
    • if the robot was stopping mid-clean for a recharge and the charging is interrupted (e.g. the robot is removed from the charger) then it can no longer be sure that it is in the same place when it is reconnected, so the cleaning session is abandoned.

    If the robot cleaned the whole place when you pressed the button, then my bet is on some temporary disturbance which prevented the robot finding its way to the remaining uncleaned area during the scheduled clean. See how the next scheduled cleaning goes.

  • I have the same issue. Trying to download the firmware but the download is not completed. Everytime it gets closer to the end, it loses connection. Tried with several web navigator, chrome, internet explorer, edge... Can you send me the file so I can try to upgrade my robot and make it work?

  • markTmarkT Member, Administrator admin


    I have just downloaded the firmware from the links further up the page and there is no problem with the server. Which robot model do you have (9 or 9.2)? I can try to send the appropriate firmware to you attached to a message, we can see if that works better.

Sign In or Register to comment.