Constant messages "cleaning cancelled because of an error"


Over the last few days my app has given me frequent messages saying "cleaning cancelled because of an error". The robot itself displays no error code. Sometimes it also varies this theme by saying "cleaning cancelled by you" even though I haven't (usually) cancelled it.

I have observed it running today, and this seems to be the pattern:
1. The robot starts normally
2. A few seconds later, the app says "cleaning cancelled because of an error" but the robot keeps going
3. Another random time during the cleaning, the app gives the same message but the robot keeps cleaning
4. The vacuum motor turns off, the app gives the same message and the robot looks for the charger
5. If the robot finds the charger, the app gives the same message again
6. Charging continues as normal
7. When the robot starts up again, the app gives the same message again
8. The cycle repeats again

This means I've received this notification more than 10 times today! Possibly related, the map has not shown up for the last few days either.

I have tried restarting the robot and force stopping the app - neither fixed the problem. Any other ideas?


  • I used to have that. Haven't seen it in a while (new firmware) but now all of the cloud services just don't work, i.e. I haven't had any notifications nor any maps in about a week.

  • AmyAmy

    Thanks. I also have the same map issues that you described in the other thread.

  • RafaelRafael ✭✭

    Same here with the constant messages! The cleaning just started and a message already pops up at my phone "Cleaning complete, but I could not find home". A little bit hard to understand the cleaning was completed in less than a minute whereas the robot is still cleaning.

  • raahlbraahlb admin
  • AmyAmy

    Thanks raahlb, here is the log. The problem seems to have mostly fixed itself now, so might have been related to last week's map issues. From memory the error messages were occurring from approx. 20-26 June. Thank you!

  • RafaelRafael ✭✭

    @raahlb , sending the logs here.

    Btw, the problem hapenned again yesterday. Thanks for helping out!

  • Mine has started doing it again.

  • Now I get a "Cleaning complete, but I could not find home" immediately as the schedule kicks off.

  • @mrmegadeth Can you send us the log when the robot say "Cleaning complete, but I could not find home" when the schedule starts the robot. And a time and date for when it happened?

  • Sure, I'll upload tonight

  • mrmegadethmrmegadeth ✭✭
    edited August 9

    Thanks for the help. Let me know if you need anything thing else.

  • @mrmegadeth I could find a short cleaning on August 7:th. It looks like the robot detects a obstacle close to the charger which makes it think it finished the cleaning. We have one item in our backlog that I think would help in this case.

    Can you take a picture of the charger and its area around it? It would be interesting for us to see. If you don't want to post it in the thread you can send a private message to me.

  • Sure, I'll post a pic tonight. The bot has been in the same place since I purchased it....this seems to be a newer issue. As evidenced by the fat that when I get those message it'll still finish the rest of the house (and I get the same notification twice each time).

  • Have you tried to restart the robot?

  • RafaelRafael ✭✭

    Same situation here. The issue started after the robot has been placed in this location. Cleaning works just fine, but receiving the notification every time a cleaning starts is a bit annoying.

  • What's strange also is that all of a sudden the runs for August are no longer logged in the monthly tally. I guess the immediate "I'm finished" makes the app think the run time and area is 0....

  • Another thing I noticed is that the notification is device dependent.

    I have another phone with the app installed and running concurrent with my main phone. When I kicked the run off today my Samsung galaxy S7 immediately got the notification saying it was finished but can't find home. The LG G6 did not.

    Maybe this is an OS issue?

Sign In or Register to comment.