Thanks for your comments and questions over the years. We haven’t been able to answer them all, but we have been able to fix problems for many of you and improve the product for everyone as a result of the conversations here. Electrolux will, however, no longer be maintaining this forum. We advise you to contact your local Electrolux service organisation if you have any problems with your robots.

Pure i9.2 does not connect to wifi (new router, wifi6)

jakubjakub Member

I've bought a new router - ASUS TUF-AX5400. Several devices are not able to connect, including Pure i9.2 (and ipad mini2, huawei P smart, google mini home). I've tried nearly everything (updated router firmware, disabled wifi 6, set WPA2-Private, limited to n protocol) so I've literally downgraded to my old ASUS RT-N18U, which worked fine with all devices.

My current setting is separate SSID for 2.4GHz and 5GHz, disabled ax protocol, WPA2-Private. I've tried to disable the airtime fairness, roaming assistant etc. but it's not working. One and only setting that helped was removing the password at all - all the mentionded devices were able to connect. I believe this issue is caused by the router, call it a feature or a bug - just wanted to share with the community and hoping a little that maybe someone had a similar issue and was luckier with the solution.

off topic: I'd like to thank you for this forum as it gave me some hints what to try and I have learned why there's an micro usb near the dust bin and how to say "firmware upgrade" in swedish :)

Greetings from Czech Republic

Best Answer

  • jakubjakub Member
    Answer ✓

    The solution is (at least in my case) to switch the wifi authentication setting "protected management frames" from "required" to "capable" or "disabled" - both work. Pure i9.2 can even work with the smart connect feature (one SSID for both 2.4GHz and 5GHz) and wifi 6 mode allowed, so it was not necessary to give up the new features.

Sign In or Register to comment.