Help! My robot cleans 1 m2 and then decides he is done but can't find his base.

I have had the robot for a week. The first day, he cleaned almost the entire area (so I know he is capable). But since then, he cleans for 2-3 minutes, changes his status to "Going to charging base" and then can't find his way. He will spin around until his batteries die. He has not saved a single map

I have tried moving all carpets from his area. I have tried turning him off and on (by pushing play/pause for 20 seconds). I have tried moving the charging base to another location. I have tried cleaning out all of his bits - making sure his "eyes" are clean and dust-free, cleaning the brush, cleaning the filter... He has the latest firmware (42.19).

If I push his play/pause for 2 seconds and then home, he drives right up to his base, looks it over, and then backs away, readjusts, drives up again, stops short of docking (by about 15 cm), backs away... spins, tries again... stops... but never gets there.

I actually like the idea of a robot, and his first clean was great. Since then, I have managed max 10m2 per day, with constant attention. What am I doing wrong?

Comments

  • kaimpskaimps Member

    I have exactly the same concern.

    How to solve it?

    Very poor application!

    firmware (42.19).

  • leighleigh Member

    I agree - the app is pretty useless, especially as you can't always convince the robot to save the map, nor can you "help" it to find new areas. Until you have a complete map, you can't give the robot a schedule or tell it where to clean.

    In the end, I sent my first robot back to Electrolux and got a new one - and it works much better. So something must have been wrong with the first one.

    Electrolux was actually helpful - and they had some good hints. However, those hints would probably be good for more than just me. It is too bad that there aren't more tips and ideas in the documentation.

    Good luck with your robot!

Sign In or Register to comment.