Single SSID WiFi

Hi, folks. While the documentation indicates the Pure i9 uses 2.4GHz networking, for whatever reason, it has a 5GHz capable radio, and is making requests on 5GHz.

This is causing it to connect on 5GHz on any network that has a single SSID (I have no choice: my network offers 2.4 and 5GHz on the same SSID)… and on 5GHz, the i9's radio performance is, to put it mildly, terrible.

That could mean one of two things: my i9 has a bad antenna and/or bad WiFi module, or the i9 is misconfigured and is making requests on a band it doesn't really support.

Any ideas what to do here? I'm at the point where I'm considering returning it.

Thanks!

Best Answers

Answers

  • Hi, @raahlb & @MartinKwarnmark - thanks for the reply.

    Can you shed more light on the nature of the problem? I'm using a Plume WiFi setup right now (http://www.plumewifi.com) and I would like to be able to provide them with the details of what's going on, and why it might be a problem with their specific implementation. Note that I contacted them first, and they performed diagnostics that determined the nature of the issue initially...

    Thanks.

  • We are not sure, but below is our theory.

    Most likely it is due to us not specifying the band we want to use when we look for APs. Normally the signal will be so weak on the 5 GHz band, as our antenna does not support it, that we will not detect it. Probably the problematic routers have better antennas or send out a stronger signal.

    An idea - maybe you can on-board the robot in a different room from the wifi AP, making sure the signal is weaker?

  • Interesting. Modern devices that do band steering are going to look for connection attempts on 5GHz and encourage that use, because in general it's a faster, more performant and less interference-prone band.

    Because you're making the request on 5GHz with an antenna that doesn't really support it (it's too bad the radio is capable, but the antenna setup isn't), and the Plume devices are quite "good" (and very modern(, it's seeing that request and encouraging its use.

    The i9 can maintain a connection when it's in its dock, but loses touch as soon as it starts to move...likely because the signal is so weak. But your stack doesn't then try to find a 2.4GHz connection...or it's getting steered.

    It's hard to move the device to a location where it's got a bad signal, because there's nowhere in the house with a bad signal. But it's not just on boarding - the SSID is the same. Rather, it's whenever you make a connection request. That can happen when the device turns on, or when WiFi drops and comes back, etc. It's nearly impossible to keep it on 2.4GHz reliably if 5GHz is available...

  • raahlbraahlb
    edited August 17

    Oh, you're right, my bad. Nice to have a well-informed customer! I forget that we don't bind to a BSSID, but the SSID. It might survive a wifi drop, but at least after every reboot it will mess it up. Hm, so then you'd have to block the 5 GHz signal by the charger station. Quite a bother.

    You don't have any possibility to give the 5 GHz ID a different SSID?

  • Nope. Neither the Plume, nor the eero, nor most mesh setups (which I greatly prefer) allow separation of 2.4GHz and 5GHz. Most modern devices have no problem with having everything under a single SSID - plus, less airtime advertising SSIDs means better performance in general on WiFi.

    (Plume even has its guest and isolated network support under a single SSID, which is quite interesting and useful: check out HomePass on their site.)

    Well, if you need an external tester to verify your 5GHz fix, let me know...

  • Ah, I see. Yeah, our product is the off one.

    Will do!

  • @raahlb & @MartinKwarnmark --

    As requested, I waited. I saw that the new app came out and figured there was a new update, so I plugged the Pure i9 back in and gave it a shot.

    The firmware installed, but now it won't connect to WiFi at all.

  • Ouch!
    Are you sure you have a 2.4 GHz network running also, not just 5 GHz?
    The latest patch completely disabled 5 GHz networks.

    Regards

  • I'm certain. @raahlb - I have many 2.4GHz-only devices on the network.

    Not only that, Ichecked carefully with the WiFi manufacturer, using their logging, and it's still advertising 5GHz capabilities, so it's getting band-steered to 5GHz, which it can't connect to at all.

    So it's literally saying it has 5GHz capabilities...but now that you've disabled the 5GHz radio, when it gets band-steered to its highest speed, it can't connect.

    The result: it's worse than before.

  • Hm, I see. Very sorry for your experience - will have to investigate.

  • Dnanian, here's a suggestion I had to do with my Orbi and neato once before. See if the plume has the option to enable a guest network. If so enable and split the 2.4 and 5 GHz on the guest. Then force the Pure to the guest 2.4.

    This will keep the rest of your items unaffected but let your pricey toy work correctly.

  • Plume doesn't allow you to separate 2.4 and 5GHz bands. Honestly, these days, it shouldn't be necessary...

  • Ok. Just a thought. Every other mesh I've used does.

    For what it's worth, no issues on an Orbi.

  • I haven't seen it in Plume, eero or Google WiFi, so I'm not sure who offers splitting the network other than Orbi, which isn't technically a mesh at all...it's just a base station with satellites.

  • edited September 24

    Orbi is a mesh. It has a dedicated backhaul to set up the mesh. It can daisy chain of it needs to.

  • I think it's arguable, but I understand your point. :smile:

  • @raahlb said:
    Hm, I see. Very sorry for your experience - will have to investigate.

    Has the team managed to get anywhere with this? I’ve been waiting patiently, and it’s been months. I’m well past the return window, and am still unable to use the device due to its bug,,,

  • dnanian, we've been looking at the issue. We cannot see that the robot is listing itself as 5 GHz capable. Do you know which parameter or flag is it that Plume say they look at?

    Is it possible that the Plume unit steers the robot to the 5 GHz network, because it has previously seen the robot on it? Some band steering algorithms seem to be implemented that way.

    We've seen some mentions of people disabling the band steering on the Plume. Is this an option for you?

    Regards,
    Rasmus

  • @dnanian, also, what is the model/product number of your plume units? I've been mailing Plume and they asked for this info.

  • Disabling band steering to accommodate one device isn't really an option, sorry.

    I'll write you privately with some additional contact information that should be useful to you.

    The devices are Plume SuperPods. They really only have two products - original pods and SuperPods.

Sign In or Register to comment.