Pure i9 Not Charging - Batteries Dead

jcrgjcrg Member
edited December 2018 in General

Having trouble with my Pure i9:

Batteries are completely depleted and are not charging. When you put the robot in the dock the screen flashes "OFF" and then nothing happens.
What can I do? Any help?

Comments

  • RichieBRichieB Member

    Unusual. Is the wall charger switched on, and the wire to the base connected securely?
    It sounds like power isn’t getting to the base/contacts to me. Usually, well in our case, if the battery is depleted, the i9 chirps up once it’s accepting charge again. Then it displays all manner of lights and numbers as it reconnects to the world.

    Just as a sideline, we had/have another manufacturers version, it was not cheap either, and this had very little technology compared with the i9. It was “alright, if not too interactive at times”, but once you have compared the two, it’s quite good value, ...plus the i9 has a very large international manufacturers product service behind it, the lesser version didn’t after three years, they are painful to contact.

  • pierrepierre Member

    I am facing the same problem as jcrg :
    The robot is "OFF" and does not react when I place it on the charger.
    when I put back the robot on the base it reads for a few seconds "OFF" and lights off, but the robot does not charge anymore. I removed the batteries and put them back in again : no change. I tried to check the voltage on the charger, but I see that the voltage appears on my Voltmeter, but I do not know what to expect. On the new version of the iphone app (app 6.0), it says that the software of the robot is version 35.15, and the battery is very low. Any help ?

  • pierrepierre Member

    The (very polite) support indicated to me that usually this type of problem is faced when the contactors are dirty.
    Unfortunatelly a thorough cleaning did not resolve the issue.

  • NiclasKNiclasK Member, Moderator admin

    @pierre The voltage should be about 22 V.

    Make sure that you have cleaned the charging pads under the robot and the pads on the chargingstand. Also make sure that the adapter is plugged in properly (both in the wall and in the chargingstand). If this doesn't fix the problem, contact support again.

  • pierrepierre Member

    @NiclasK
    Indeed the voltage is around 22v on the charging stand/base.

    I had cleaned the pads under the robot and on the chargingstand ; but I cleaned them again (with a household /rubbing alcohol, recommended by the french Electrolux support ) and finally it worked, the robot was charging again.
    It was probably the pads on the charging pads which were very very slightly dirty.
    So, thank to your help, the problem is solved.
    Thank you so much.

  • ads19bads19b Member

    I'm having this exact same problem with my Purei9 and it's only 6months old. I've tried all of the above fixes and still have the E23 error and no charge. The batteries should be replaced with warranty being so new?

  • whibswhibs Member

    Thanks @pierre the rubbing alcohol worked perfect. Thought I was going to have to order new batteries but this trick got it charging again

Sign In or Register to comment.