Purei9 does not return home to charge when on schedule

Dear Purei9 forum,

We just purchased the Purei9 to keep our floors relatively dust free. While it does start to clean according to the schedule we set up, and actually sweeps up quite a bit, it fails to return to its home-base to charge before it exhausts its' batteries (and cannot continue its chores...). However, when we press stop during a cleaning cycle, it does return home as it should. This makes no sense! Please advise! We have 34.16 installed.

It seems that the software ought to tell the Purei9 that if there are "unaccounted" areas (or medium ply rugs identified), return home at 10% battery power...

Best regards,

Hans

Comments

  • Hi Hans
    The robot normally does exactly what you suggest- when the battery is low, it remembers where it has yet to clean, then returns to the charger to top up the batteries before resuming the cleaning session.

    Unfortunately it seems that in your case the robot gets lost on the way back to the charger. It will continue to drive around for as long as it can and look for the charger until the batteries run out- this seems to be what happens in your case. You can tell when the robot is on its way back, as the "home" button is lit on the display, and the vacuum motor stops running while it is driving around (it is much quieter in this phase). You should see the robot running this way for a while before it stops. If not, then there is some other problem.

    It is very hard to say why the robot gets lost- each home is different and the reasons can include tricky rugs or thresholds among other things. Try starting the robot from a different position, or (if you can) move around some furniture and rugs to see if that makes a difference.
    Hope that helps,
    Mark

  • Dear Mark,

    Thanks for your response! However, while on a scheduled clean, the robot never even tries to return to home, i.e. to the charger. The robot cleans until it stops and shuts off for lack of charge. We have moved the charging station around, but only to have the same thing happening. Only when we stop a clean, such as 20-30min into the work, the robot returns home fine; hence it is not the position of the charging station that is a factor.

    We have been following the cleaning time, and it seems we get between 36-38min on a charge. Could it be that our batteries are faulty, and the robot cannot sense an incorrect rapid decline in power? That would explain it....

    Please advise! I have called customer service a week ago but no reply as of yet...

    Best regards,

    Hans

  • Hi
    I have the same problem, the robot just stop where ever the battery is flat and didn't try to return to charge. I called the service dept and they ask me to remove the battery and reset the robot and the app, but it still doesn't work.

  • Obviously this is then a problem that relates to the software that directs the motion control (easy ELUX fix) OR inability of the hardware to sense the correct battery level (difficult ELUX fix). I have contacted Customer Service in the US, but no reply as of yet (72h and still counting).

    Best regards,

    Hans

  • Hi Hans,

    I have contacted the US support team now as well and they should come back to you asap. It seems that it is not an issue with a quick fix and the robot has to be replaced.

    Sorry for any inconvenience, we are working on this now.

    Any further questions, please let me know!

    Thanks,
    Ines

  • I bought the machine in Australia just four months ago, I rang the customer service here and they ask me to remove the battery and reset the machine and the app, I done all those but still doesn't work. The machine just stop where it was when the battery is flat.

  • Is there a better way to contact the US support team other than phone or e-mail? I have not yet heard back after more than a month, and multiple attempts using each channel...

  • It does not seem that the US market customer service e-mail nor telephone voice mail inbox is being monitored and addressed by Electrolux...

  • I have found the same thing @hans I tried to get a hold of them too and nada.

  • Problem finally resolved BUT it should not be like pulling a tooth

    After months (August through October) of multiple tries to reach [email protected] and by phone, I resorted to contacting Electrolux support for Sweden ([email protected]) to let the HQ know of the terrible customer service that the Purei9 have in the US, along with the specific issue that I had encountered. Roughly 72h later, I got a call from the US, and a RMA to send the unit back. Four weeks later, and one call (two weeks in) to Purei9 USA informed me that a new unit would be imminently sent out; but not receiving one, I contacted the HQ and a person in charge for the US market, and 96h later a replacement unit appeared at my doorstep. Needlessly to say, the replacement vacuum works flawlessly (=as advertised) and will certainly help to tend to our home's cleanliness!

    The Pure i9 robot vacuum is probably the best product on the market, and I do recommend it as is. However, the US customer service is sub-par, which significantly diminishes enthusiasm. I can only hope that Electrolux will remedy their situation and put in place a post-sale organization that is comparable to what competitors have and what US customers have learnt to expect. Moreover, as a native Swede, I am sad to see that Electrolux fumbles on the US market.

Sign In or Register to comment.