Brand new Pure i9.2 is completely dead. Frustrated and I need help.

MarkqqMarkqq Member

Brand new product and it is not working at all. When I put it in charger/dock, Play/stop, battery icon (red colour) and triangle with exclamation mark inside start flashing. After a while battery icon stays stable red but those other two keep flashing. Then suddenly every icon shuts off and nothing happen. The device is not charging at all and basicly it is a dead product .

I tried cleaning the charging contacts, took off batteries, tried to plug in and off the dock, pressed play/stop button for 10 seconds. I tried to connect it through micro USB with PC but it's completely blank. I tried every single thing to wake this thing up.

Now I think the product is faulty or somehow the software inside is just messed up badly. I contacted Electrolux support but I get no respond.

This may be the last Electrolux product I am ever buying because the experience been like a hell with so expensive product.

Answers

  • HotkiwiHotkiwi Member

    If it is newer than a week, just go back and replacement.

    I also bought the Pure i9.2 Animal. Hopeless robot. Will not connect to your mobile.

    Forget the aftersales service of Electrolux better as well. Once sold their interest is gone.

Sign In or Register to comment.