New Pure i9.2, can not connect to app

HotkiwiHotkiwi Member

Hi did everything right with installing the app and connecting the Robot to the app, but stalls in the last few steps. My network is 5 and 2.4 GHz, but even if I set the router to 2.4 GHz only the robot will not connect.

Comments

  • HotkiwiHotkiwi Member

    Is there somewhere a photo series or a video that walks one through the app setup to connect the robot ? My phone keeps turning its search mode, and the robot is displaying a blinking network connection icon.

  • HotkiwiHotkiwi Member

    Tried many times and made some progress, but it stops at the screen attached: Trying to find Hugo. Verify if you are connected to The Zoo. When looking at my settings I am connected to The Zoo (my network, a Netgear Orbi, working at both 2.4 and 5 GHz).

  • HotkiwiHotkiwi Member

    The screen showing:


  • HotkiwiHotkiwi Member

    Resetted everything and tried again today. No progres.............

  • HotkiwiHotkiwi Member

    Phoned with Electrolux Australia helpline. First very knowleagble lady who said I should keep it upside down over my head and it should display HOTS. Which it did not do.

    She asked me reset everything, incl the home network. Reinstall the app on the phone and retry after 20 minutes. Sounded she knew what he was talking about.

    Phoned them back as nothing had changed, atill stuck at the 75% mark (see above). Tried to redo all on a different phone after yet another reset: same thing.

    He did not listen long, said there must be something horribly wrong with the robot, and since I have it only for 1 day, bring it back and ask for a new one.

    Wonder how this will go. Electrolux could have walked me through the app, but no, will get a new robot now.....

  • apjapj Member ✭✭

    @Hotkiwi Sorry to hear about your frustrating experience!

    The newer model 9.2 unfortunately no longer has the LCD and hence will never display HOTS it must however be upside down during the entire enrollment.

    Did you try with the new "Wellbeing" app or the older Pure i9 app? My understanding is, that the new Wellbeing app still has some issues while onboarding so it might be better to do the onboarding with the old app and then switch over to "Wellbeing".

  • HotkiwiHotkiwi Member

    Hi Thanks for your comments, apj. I used the Electrolux Pure i9 app. I did not know about a wellbeing app for the robot.

    I am less than enthusiastic about Electrolux helpline though. Every time they tried me to have it reset and call them back in 15 minutes...........

  • apjapj Member ✭✭
    edited December 2020

    I found this video which shows the onboarding process for the i9.1

    Depending on the "shelf-life" of your robot, it might even be helpful to manually update the robot to the latest firmware as outlined here - older firmware releases had some quirks with WLAN steering (and others).

  • HotkiwiHotkiwi Member

    Thanks for that. Nice video. Regretfully it does not show all the steps of the app instalment. Only the start and then suddenly all bullets are ticked. Mine stops at 7 out of 9. Maybe the last guy that I had on the phone and who did not want to spend too much time on it was right and it is in error in the robot. Or the app is not ready yet for the 9.2 model.

    Will have a look at that firmware tip though, it makes sense.

    Thanks so much for supporting me with this, really appreciated.

    Johan

    Perth

    Australia

  • HotkiwiHotkiwi Member

    Have now a brand new Pure i9.2, exactly same problem.

    I wonder if it is the firmware, but can only find on a swedish website an update in swedish.


    Where do I find the latest Pure i9.2 firmware update ? Now that I can not install the app, can I still install the latest firmware on the robot ?

  • HotkiwiHotkiwi Member

    Will go and get my money back. Bought it for 1199 $ with the offer of 60 days no questions asked return. Electrolux makes good fridges, understand nothing about fobots, worse there is no support. Every time they just tell me to just reset the router. Sick of it.

  • AndersJAndersJ Member ✭✭

    The legacy app will no longer connect to my robot.

    No idea why, it just will no longer communicate.

    iPad with most recent IOS.

    Why are there constantly various issues with this product?

    And why do I get a empty line every time I press Enter?

  • HotkiwiHotkiwi Member

    Now got a message the i9 app is replaced with the wellness app. Does not work either !!!

  • HotkiwiHotkiwi Member

    Hi Anders. Exactly the same here.

    Electrolux remains mute about it.

    They sold the expensive robot and that is it for them.

    Do not trust them with other appliances anymore either.

  • AndersJAndersJ Member ✭✭

    Before I had these connectivity issues I had changed to a new router.

    The new router had various connectivity issues,

    and when I finally had enough, I changed to yet another router.

    And voila, the Robot now connects without problems.

    Not sure about the real causes here,

    but possibly some routers are better than others.

    It might not always be the robots fault when shit happens.

  • HotkiwiHotkiwi Member

    Hi Anders, the problem is solved. I was contacted by Electrolux Sweden as Electroluc Australia had no idea. Late November a firmware update was released that was no longer compatible with the latest Apple OS. I had to go through a complex process of buying a cable that connects the USB port next to the bin on the robot, to the computer. Then download a newer version of firmware to my computer and install that on the robot. After that it all worked fine. Had nothing to do with my router. I am computer savvy, so had no problem with all this extra work, but feel sad for the elderly who bought an Electrolux robot and can not use it.

    Also, the problem was identified in Sweden in late December, but Electrolux Australia had never heard of it.

    A company with communication issues.

  • frekanfrekan Member, Moderator mod

    There are a few threads on this topic so I will post a link to the solution here to save future visitors some time:


Sign In or Register to comment.