Error msg e:42 Internal Error - what to do?

AnnaHAnnaH
in Q&A

Just got an purei9 and after 30 sec it stops and displays Error message 42 and says "Internal error". After some minutes is says "I´m ready" and then barely moves out of the charging station before it stops again with same error.

No guidance in the instructions what to do in this case. Is there a way to do factory reset and start the installation process again? Tried removing the batteries for 1 h but it still has the settings for wifi etc.
Can I remove it from the app in order to reconfigure?
Is there hope or should I return it to the store?

BR, Anna

Best Answers

Answers

  • Running version 34.16. It did upgrade upon startup.
    Attached are the error messages.

  • AnnaHAnnaH
    edited July 9

    @MartinKwarnmark

    After I cleaned it in order to go back to the store I decided to make a last try. Now it worked and cleaned nicely for about 20 minutes. It did get tangled and stuck in a rug ("mattfransar") once during this time. Then it gave up and gave it favourite message; E:42. Now we are going to get it replaced!

  • Now I managed to get it replaced in the store!
    The new one is working but keeps cleaning the same are all the time. Our floor plan is big (200 m2) and it does not move far away from the charger.
    -Is there a way to get it to pass areas it already cleaned?

  • P1rP1r admin
    edited July 12

    Hello AnnaH.

    Great to hear that the new unit is working!
    Is there any narrow area, threshold, carpets that might be blocking the robot from reaching the rest of the apartment?
    Can you see what happens if you start the robot in a different location?
    Have you upgraded to latest SW version?

  • Hi,
    There are no obstacles thet stops it from moving to the rest of the house.
    I think the main problem is that it did not find its way back to the charger and therefore restarts the map at each time. I have set a schedule and when the battery is empty it gets lost and I finaly return it to the charger. It then waits for the next day to start cleaning. I would like it to continue after charging.
    It does have the latest sw version, 34.16.
    We now have to put it in a new room/area each time. Would be great to have it move around by itself.
    BR,
    Anna

  • P1rP1r admin
    edited July 13

    Hi again Anna, thanks for the input and good that you have the latest software installed!

    Yes the normal behavior is that the robot continues cleaning all areas that it can reach. If the batteries run low it then goes back to the charger and in the app it will say something like "pausing for charging" then after about 2 hours it should go out and continue cleaning where it stopped.

    But you are correct, if the robot gets lost it will not remember the previous clean and start again from start.
    The questions is why it gets lost, do you have many carpets where it cleans?
    If possible it would be interesting to know if the behavior is different if you remove the carpet(temporarily for testing). If you could provide a picture of the carpet this could also give more input for us to understand the issue.

    Also if you could provide a screenshot of the map in the app.

    Best Regards

  • ![](https://us.v-cdn.net/6030885/upl

    oads/editor/ft/r2vqvod8vo3d.png "")

  • S
    ome

  • AnnaHAnnaH
    edited July 13

    Some pictures and screen dumps from app. We have lots of rugs like the one in the pictures.
    At 15 pm today it said finished cleaning and had done 11 m2 out of 200. It was not near the starting point when stopping.
    Hope this helps, glad to provide more info if needed.

  • P1rP1r admin

    Hi again and sorry for the slow response, vacation got in between.
    Thanks for taking the time and sharing the pictures.
    Some specific carpets give the robot problem since it experience a lot of slip which then makes it hard for the robots to maintain a reliable map of the home. If the carpet in your case is one of these carpets is hard to tell for sure but it is very likely.

    It would be very interesting to try without the carpet to see the difference to know for sure but I understand that this is not so easy since there is sofa and other furniture on it.

    Best Regards

  • I just responded your collegaue Martin in another thread. It is working better now but gets lost frequently when returning to base. I have been watching it and can not figure out the algorithm it uses :) It has problems also when there are no carpets.
    We do solve it by manually moving back to base, works fine that way.

Sign In or Register to comment.