Small threshold problem

Hi, I'm trying to get my i9.2 to clean a bedroom. It drives in easily but can't find it's way back. The floors differ slightly in height, about 2.5 cm with the robot coming from the higher level down onto the bedroom floor.

When going back out, it does it's standard going over a threshold dance, but every time it decides that it won't work. It has only gone over it once when it didn't register the height difference and drove over at an angle. So the height can't be the problem, it seems as though something else is causing this.

I've attached the floor plan and actual photos below:


I have tried putting a different colour on the opposite wall, putting a thin grey mat over the dark outer floor, lights on and lights off. Each of the "ledges" are about 1cm give or take.


Would love to get this problem solved as it is the only trouble spot we have before we can utilize the bot as we had envisioned.


Thank you in advance for the help!

Comments

  • FreyFrey Member

    I have also tried putting the charge station in different locations, inside and outside of the bedroom so it should not be a factor.

  • frekanfrekan Member, Moderator mod

    Hi,

    Based on what you describe, I think that the robot thinks the threshold is slightly too high for it to climb, even though it may be physically able to do so in this case.

    What you might want to try is to put something like a doormat on the lower side of the threshold to reduce the step height by a few mm. Not an ideal solution for sure, but may be worth trying.

    Let us know how it goes!

  • FreyFrey Member

    Hi and thank you for the answer. Yes, it seems that this was the problem, a thin doormat solved the issue. I think the difference in height of the floors is what causes this as the robot will barrel over higher thresholds here at home.

    Too bad you can't put "green zones" over areas that the automated system won't allow but that the bot physically can do without issue.


    All in all, the mat workaround will have to do in the mean time.


    Thanks a lot again for the help! Will post if the issue returns or I find another solution.

Sign In or Register to comment.