Two days ownership and already can't find the charging station!!

BPoulterBPoulter Member

I've had my i9-1 for 2 days. First day I used it in one room and it found the docking station, twice. Last night I "upgraded" the software and now it won't find the docking station if i set it right in it while it's running. I pause it and sit it in the dock and it charges. Start it up and let it leave the dock, it has no clue where the dock is after that.

Hard to believe they have been selling these for two years and their app, cloud, and perhaps firmware are so "childish"! Yea, I think a grade schooler could do better programming. Unbelievable!

My question is this, is the docking station an active device, meaning does it provide a homing signal for the robot or is it just a dumb charging terminal? If it relies on the cloud, like GPS, then it is a lost cause because the cloud appears to be a joke.

Answers

  • BPoulterBPoulter Member

    Well, it appears I may owe someone an apology.

    After watching my i9 chasing its tail and spending its whole battery charge on one standard size room and the things I mentioned in my earlier post, I was really perplexed and couldn't believe this product.

    After a lot of searching and reading a lot of reviews, I realized that just too many people are generally quite happy with their bot. What the hell is wrong then with mine as well as a bunch of other people's device?

    I had a thought. I'll download the program and install it manually. Maybe it's getting corrupted via wifi somehow.

    I now have a bot that does what they say it is supposed to. I'm thrilled. Now I don't feel so bad about the money I spent on it. Hopefully this will help someone else with similar problems.

  • SamiSami Member

    How donyou install it manually. I have had the same problem for months now...


    Also tried to create a new robot, because of changing the wifi, but that doesn't work either... On the last step it just doesn't find the wifi.

    First half year the robot worked perfectly. Now it has been uselles for several months

  • BPoulterBPoulter Member

    I found this in a Swedish website. Go to the page, right mouse click and click translate to english if using Chrome. Even has pictures! :-)

    https://www.electrolux.se/wellbeing/discover/robot-vacuum-cleaner-purei9/software-update-with-usb-connection/

    I hope it helps you. Mine did the whole house. It worked in a logical manner, went back to charge and then resumed, TWICE, but when it was all done it couldn't find the base. I was pretty disappointed. It did all that then faltered. Oh well, at least it will clean my house now.

  • SamiSami Member

    Thanks, i'll give it a try! Swedish is not a problem. Det är ingen problem :)

  • SamiSami Member

    Unoftunately didn't help.

  • BPoulterBPoulter Member

    WoW. Sorry. It made night and day difference in mine. Too bad Support isn't more forthcoming with help.

  • apjapj Member
    edited July 28

    @BPoulter said:

    ... I pause it and sit it in the dock and it charges. Start it up and let it leave the dock, it has no clue where the dock is after that.

    Please note you have to cancel the cleaning session first, if you want the robot to find the base station if you manually move it. To do this, press the play/pause button until you here to beeps (about 2 seconds).
    Then set it in front of the base station and press the home button. The robot will turn full circle and then head straight for the docking station.

Sign In or Register to comment.