Mapping new floor - Issues

Hi,

I just bought a second charger to be able to use my robot on a second floor. I have been trying to map this floor now for several days but a number of issues has occurred. I’m now trying to map by adding room by room but no success.

Room 1 is Ok (Position of the home)

Room 2 I a hallway which I have restricted.

Room 3 is the one I’m currently trying to add to the map.


The issue: once in room 3 the battery runs out and it need to return to the home. The correct path should be like bellow in green (doorways marked as yellow). The actual position of the robot is the red ring but for some reason it thinks it has jumped through the wall and is in room 1. The result is the robot bumping against the wall in room three until the battery runs out. I have now tried to restart the mapping over 5 times but always the same result.

The first tries I did with no restrictions and a few times it found its way into room 1 from the hallway (not returning from room 3). Then I experienced the same problem I read from other users, it couldn’t dock to the charger. It recognised the home but constantly missed the docking by 10-15 cm.

on the first floor it has worked flawlessly so I really don’t understand what the problem is. The second home is placed according to the manual.

What could be the problem?


/Johan

Answers

  • What kind of floor is there in rooms 1, the piece of 2 that it transports through, and 3? Hardfloor or carpets? Floor-level mirrors on the wall? From your description it sounds like it loses track of where it is in room 3.

  • Hi, your suspicions are totally correct! After reading up I realised that carpets are the enemies (carpeted floors in both room 1 and 3). I just assumed that the robot would handle carpets. For now I will skip to these two rooms, set them as avoid zones and manually vacuum them. I also moved the home to another location and it now finds the charger every time (even though it’s tucked into a corner next to a bed).

Sign In or Register to comment.