38.7 software update

After the software update which I performed yesterday in the evening my Pure i9 has decided to completely ignore significant part of the apartment today, and it took him the same amount of time to clean 25 sq.m. as 35 sq.m. the day before (i.e. the cleaning speed decreased by more than 30% - see images below) - do you have any idea why this happened? Did anybody else encounter the same problem?

0 votes

Active · Last Updated


  • raahlbraahlb admin

    Is there a threshold at the location the map is cut off at?

  • No, there is no threshold at that place.

  • Now I tried to start the cleaning again, and it managed to clean even smaller area, then returned to station... It never performed so poorly before.

  • raahlbraahlb admin
    edited May 23

    In that screenshot it's doing a pitstop. Was the pitstop quite early? For how long had it been out? What did the final cleaning look like?

  • It apparently wasn't a pit stop, as it did not continue cleaning the apartment after it charged itself. It returned to the charging station after ca. one hour, which is normal, however what is not normal is the cleaning speed - normally it never has to recharge itself during cleaning, as it can manage to clean whole apartment at once (first screenshot above from 21 May).

  • raahlbraahlb admin

    If you send me the rbl file from the USB device accessible under the dustbin, I can take peek at what happens.

  • Attaching the file. Yesterday, for example, it seems it cleaned for ca. one hour during scheduled time (based on data from sound sensors at my place), however there is no track of such cleaning in the app - it said it cleaned 0 m2.

  • raahlbraahlb admin

    Realized that I misinterpreted the screenshot from the 22nd - it's not doing a pitstop, it's charger after completing a cleaning session.

    There is a known bug that the map can be missing or incomplete and the cleaned area listed as 0 m2. I guess it's hard for you to make a guess about how the cleaning went? Looking at the debug logs, it seemed to do a full cleaning of the apartment, taking about 55 minutes to do so.

  • Well, yes, it's hard to make a guess about how it went when I'm not at home. Therefore I assumed the map is providing an accurate image.
    Nevertheless, few times that I actually was at home, I also realized that the vacuum decided not to clean some parts without any clear clue why, as there was no new obstacle on the way. In general, apart from kitchen chairs being at slightly different position (however never obstructing access to another room), whole my apartment is constantly accessible in the same way.

  • So I've just had an opportunity to watch it clean during the whole process, and now it makes sense to me why it takes longer and it sometimes need to recharge during cleaning - as opposed to previous behavior, it moves in an extremely chaotic manner, has problems on places where it used to move smoothly, bumps into objects it had no problem avoiding before (and tries to get "through" them by bumping into them several times in a row), gets stuck at places with no obstacles around, has problems finding his way back to the charging station or gets discharged on a way there (happened this week), and so on... Attaching the latest file downloaded from the vacuum.
    Would it be possible to downgrade to the previous version of the firmware?

  • When I start the cleaning from a room without a charging station it is supposed to return to the starting point when finished. Instead it runs around in a chaotic manner, maybe in panic, after a while it feel shy and hides in the dark. Suggestion: If it got lost – try at least to stop in a bright area.

  • Yet another surprising development! Today it has managed to bend the space and completely change the layout of my apartment while cleaning. Thankfully, every room was back on the same position when I came back home. (see attached image - today's cleaning on the left, real shape of the apartment on the right)

  • raahlbraahlb admin

    @eLPii - Sadly cannot see anything weird in your logs. Is it possible for you to record a video of it bumping the furniture? Also, what's the floor like where the charger is located?

    @Ulf_Ason - It cleans the whole room/apartment and then is confused? It's not just the cleaning pattern that feels weird to you? Is it always running with the fan on?

  • It's a hard floor, like everywhere in my apartment (I do not have a single carpet except for one door mat). I will try to record the video. It has particularly became confused by legs of my sofa (see image below) - I saw it deliberately bump into one five times in a row. Before the update it didn't even touch them.

  • raahlbraahlb admin

    Ah, OK. Metal legs can be hard for the sensor to spot, as they'll reflect the laser. Not sure what could have changed in the latest release regarding it, though.

  • @Ulf_Ason - It cleans the whole room/apartment and then is confused? It's not just the cleaning pattern that feels weird to you? Is it always running with the fan on?

    @raahlb - Yes, It cleans the whole room, it turns of the fan and then got confused while it tries to find the starting point.

  • NiclasKNiclasK admin
    edited June 19

    @Ulf_Ason - When the robot starts on the floor and not in the charger, it will look for a charger when it is cleaning. It sound like it has seen something that it thinks is a charger, but whenit gets there it is not. It should then continue to the the start position. It sound like a bug that it is not doing that. After the next run you do, where the robot behaves like this, can you collect some debug info for us? see https://community.purei9.com/discussion/260/collecting-debug-information-for-troubleshooting
    You can attach the log in the thread.

  • J_RJ_R

    Let me join this topic. Today I ran the cleaning 3 times and none of them covered all the house. In the morning it hadn't left the starting room (1 of 5 rooms cleaned) there was no pit stop, it just finished the job. The 2nd time - exactly the same situation. I almost lost all the hope but... on the 3rd it cleaned the starting room and went to very last room at the end of the hall ignoring 3 other bedrooms, kitchen and both bathrooms. After that it spent 45 mins in the last room cleaning it probably 3 times (or more) - Then it got back to the charger for the pit-stop (return took it almost 15 mins and watching it tryng was like a real fun - I think 'Odysseus' would be a good name for it) When recharged... it traveled back where it stoped - not sure why - guess to finnish the cleaning(?) and after a half an hour it got back to the charger ignoring all other rooms in the house. I thought it's just not a very smart robot and wanted to propose that there should be an option to show to the robot on the map a location of all of the room in the house to 'help' it find all the areas it should work on, but... it appears it's just a crappy software that is installed. My question: Is there any chance to have that improved / fixed? To be honest at the moment it's the stupidest robot on the market. The friend of mine uses Xiaomi roboroc2 and it's a way, way better. All her flat is cleaned every day. No areas left untouched by the robot and for the past couple of months since she bought it, there was no even a single situation when the robot couldn't find the charger. That means - having a good software is possible. Can't you just buy it from the Chinese guys?
    Looking forward for the software update - this is criticaly needed. Apart from that the robot is awesome. Please don't ruin it with this... software.

  • J_RJ_R

    new day & new disappointment
    today robot cleaned 8 of 90 m2.
    I kicked it off twice - same result.
    it's less than 10% of the area that should be cleaned.
    Really considering to give it back as a 'broken' and demand to get back my money.
    When can we expect a new software release please?
    Is there any ETA?

    Thank you.

  • Can Purei9 fly in the sky?

    There is a problem drawing the map.

    The attached image is a screenshot after cleaning. The cleaning seems to be complete.

    iPhone PUREi9.app ver.6.4

    Purei9 ver.38.7

  • AmyAmy

    Mine did that a couple of days ago too.

  • Purei9 became an idiot.

    Purei9 doesn't know where the house is.

    Purei9 goes back and forth in the same place for 15 minutes.

    I feel frustrated to see the purei9 movement. I gave up.

    I grabbed the Purei9 and set it up at home.

    Last year, when Purei9 came to my house, I felt very smart.

    Why did he become such an idiot? I am very sorry for the current situation.

    iPhone PUREi9.app ver.6.4

    Purei9 ver.38.7

  • New feature - Purei9 runs completely out of battery in case it gets stuck somewhere. Happened few times already. Previously it was able to pause itself after few attempts, and then when moved a little simply continued with cleaning. Now it doesn't have enough energy to even light up the buttons.
    Can we PLEASE roll back to the previous firmware? This is a disaster.

  • I'll elaborate.

    When I canceled the cleaning, Purei9 got lost and couldn't go home.

    Purei9 goes back and forth in the same place like crazy.

    When Purei9 returns home for charging, purei9 returns home correctly.

  • I just got my unit back from service (after) not using it for a few months. The new firmware works wonders so far for me (haven't completed a full cleaning yet - but my apartment is huge).

  • @Thomas said:
    I just got my unit back from service (after) not using it for a few months. The new firmware works wonders so far for me (haven't completed a full cleaning yet - but my apartment is huge).

    Now I have conducted a few test-runs and it finds its way back every single time so far. A really happy customer right now.

  • @raahlb said:
    Ah, OK. Metal legs can be hard for the sensor to spot, as they'll reflect the laser. Not sure what could have changed in the latest release regarding it, though.

    But you changed something as you mentioned here:

    @raahlb said:
    @DeLol, hm, we should have not changed that part. Interesting!

Sign In or Register to comment.