New product, cannot connect to wifi

Purchased a new i9.
Trying to get the app to work.
Can scan the barcode and then 9/10 you can’t see the 3vision wifi.
If by some chance I can see that wifi to connect to then it connects to my home wifi but then says this will take 10 seconds then this is taking longer than expected you may have to restart the process.
Have tried this many times same result every time. Have tried on a phone and tablet (both apple).
Have powered it all off etc. any ideas?

Comments

  • Hi,
    Are there are a lot of wifi networks in the area? That might cause interference. It could also be that the hardware is damaged, but it's hard to tell. You might have to send it in for service.

  • raahlbraahlb admin
    edited February 26

    By the way, does your phone support 2.4 GHz wifi? Is your router using 2.4 GHz? 5 GHz is not supported by the robot.

    If you cannot disable 5 GHz mode, you can try upgrading the robot first, using an USB cable. There is a micro USB connector hidden by the dustbin. You can find the latest firmware at this link:
    https://web.rvccloud.electrolux.com/home/latestfirmware?platform=0.13
    Just put it on the mass storage that appears when you plug it in, use the "safely remove" option in your file manager, then unplug the USB cable.

  • Thanks. Will try the firmware upgrade tonight. There are about 5 or 6 neighbouring wifi’s that appear. I do have 5ghz but have “forgotten that network” on my phone so it doesn’t connect - is that sufficient to disable 5ghz?

  • If the 2.4 GHz and 5 GHz network have the same name, it might still be a problem. In earlier firmwares we did not filter this properly on the robot, so it won't matter if your phone ignores it.
    Hopefully the update will help you. If not, you can use the USB cable to collect the logs - the .rbl file - and send it to [email protected], putting "Rasmus - jaymcee" in the subject, and we'll take a look at it.

  • i installed the new firmware. It installed & upgraded fine (got voice prompts telling me so). Still have same issue!

    Will take to work tomorrow & try on different wifi etc and see if that works!! Will then look at grabbing the logs tomorrow night!

  • Hi, I have emailed the logs through over the weekend.

  • raahlbraahlb admin

    Hi,
    What is the model of your wifi router?

    To finish the setup, the robot and the phone must "meet" on the wifi locally after the robot has been given the connection details.

    Some possibilities of why it is going wrong:

    • Your router not allowing broadcasts between different units on the wifi.
    • Is the phone switching back to the wifi after it has disconnected from the robot? Cellular connection is not enough.

    Does your 5 GHz and 2.4 GHz network have the same name?

    There is also another problem, caused by the problems with connecting. Not completely sure what is happening, but the robot ends up in a bad mode after trying to connect to your wifi and failing. This is the reason why the "3DVision..." network isn't always showing up. The following procedure should be able to get you into wifi configuration mode cleanly:

    • Long press play button on robot until it shows "off".
    • When the screen turns black, put the robot in the charger.
    • While the robot is still showing the boot animation, turn it upside down.
Sign In or Register to comment.