Will not charge

Came back from servicing a week ago. Now it tells me the charging base is incorrect and then the battery became completely flat and it will not charge. Before that it was not returning home but just kept on cleaning until it ran out of power. If I pressed the home button it went round in circles.
Now cannot use it at all as will not charge.

Comments

  • I have sent it back for service again. For the NZ$1600 price tag it’s quite disappointing.

  • AndersJAndersJ
    edited February 20

    Pretty much the same here.
    In addition to that, the long brush no longer rotates.

    Martin,
    who do I contact in Sweden to get this and other issues resolved?
    Please email me.

    /Anders J

  • Hi Anders,
    The customer care number is available in the application. They know about the roller issue and will help you with that.

  • eebee,
    The battery issue of your robot is unfortunate and I really hope service can help you quickly and pain-free.
    The issue with not returning to charger sound more like the robot is lost at your place. Try relocating the charger to a central position in the house.

  • Martin,
    the roller is not the only issue.
    As of yesterday it no longer takes charge.
    The charger has 22V on the contacts in the bottom,
    and the power supply remains cold,
    but will deliver 1A at 22V when tested.
    I believe the robot is at fault.

    Before it died it exhibited strange behaviour not seen before.
    It spun in circles and could not find home.
    It stopped, claiming it was stuck, in locations previously without problems.
    When physically an manually put in front of the charger it was unable to dock ,
    as if it could not connect electrically.

    The robot has worked well, with some quirks, for 6 months.
    Now, after 8 months it is dead,
    and the last 2 months it had various difficult to describe issues.

    I need the robot fixed now, or replaced with a new one,
    or returned to the place of purchase with a refund.

    Will customer care resolve this?

  • Yes, our support should be able to help you with a replacement.
    Though the charging problem could be because of the pads not being clean - have you tried wiping it off with a wet towel? Both the robot and the charger's pads.

  • Mine has returned from service and they fixed the getting lost issue and it now works as it should. They said the not charging was because the contacts were dirty although I had cleaned them with meths.

  • I cleaned the charging pads with isopropanol.
    Did not help. Still takes no charge.
    Have sent it to Electrolux for service.

Sign In or Register to comment.